[mythtv] no video with mythtv

Harondel J. Sibble mythtv-dev@snowman.net
Sun, 17 Nov 2002 21:33:00 -0800

Well after a weekend getting dual tv cards working, I am back to my original 
setup... sort of and no video from mythtv.

Basically the steps I took as I remember it are:

1) recompiled the kernel to resolve some issues I was having with he ide 
driver from my last compilation hanging on bootup.  Added the btaudio driver 
as a module etc.

2) added the 2nd tv card, the original was an ATI TV Wonder, while the 
secondary card was an Aims Labs Video Highway Extreme, after much mucking 
about with modules etc, I got both cards working with xawtv.  For those who 
want to try this, here is the relevant section of my /etc/modules.conf

alias char-major-81 bttv
options bttv card=63,14 bttv_verbose=2 tuner=2,2 pll=1,1
post-install bttv modprobe -k tuner
post-install bttv modprobe -k btaudio
post-remove bttv modprobe -r tuner
post-remove bttv modprobe -r btaudio

The last 4 lines are probably not necessary, but ymmv.

3) I installed the commercial OSS drivers and then uninstalled them as I 
couldn't control the volume wrt mythtv or xawtv from ossxmix.

Anyhow, after I got this up and running, I tried running mythtv and all I got 
was the usual info in the term window, I could hear the audio in the 
background, but, not video window. Same result if I went through 
mythfrontend.  Oddly enough before I had got both cards running I had set a 
recording to record a show.  I had everything running around the same time as 
the show would have been recorded. When I started up myth from either the 
frontend or mythtv, it would say that myth was already recording the show and 
would I like to watch recording in progress, I select yes and it comes up, 
but it's quite jerky.  Hitting V to switch to the other tuner fails. 
Basically then I have to escape to get out of myth.  I hit esc to get back to 
the frontend, then have to go to the terminal window and hit ctrl-c to kill 
the frontend, as it just sits there with the logo in the background but no 

One the recording time period was up, if I started up myth, I'd get sound but 
no picture.

Since then I've removed the second card and rerun the ./configure, make, make 
install steps, copied back my settings.txt that I'd previously backed up and 
all I get is sound but no video.

Any suggestions on what I should be looking it?

Oh just remembered one other item but I suspect it's may not be related. 
Since I recompiled the kernel, I had to reinstall the nvidia binary drivers.

Other than that, I can't think of any thing else.