[mythtv] WinTV GO and btaudio... no sound

Bruce Markey mythtv-dev@snowman.net
Sat, 21 Dec 2002 19:55:53 -0800


Robert Dege wrote:
> I too am having difficulty getting btaudio to work with my WinTV-GO (190).
> I can get line-out (WinTV) -> line-in (sound) working with no problems
> with xawtv.
> 
> However, it doesn't seem as if btaudio is capturing any data even when I
> specifically point xawtv to btaudio's digital dsp.  Even when Running
> aplay on the digital dsp (/dev/dsp1), I still receive no audio.
> 
> 
> Here's what I noticed:
> 
> when I modprobe bttv, tvaudio get loaded instead of btaudio, even if I
> alias char-major-81-1 btaudio in the modules.conf.
> 
> if I modprobe msp3400 & btaudio, i2c-core shows reference to msp3400, but
> not to btaudio.
> 
> When I run the sox command shown below, I recieve no audio.
> 
> When I insmod the btaudio module, it does detect the card, and outputs no
> error messages.

I tried btaudio a couple days ago and never got any output.
Here's what I'm guessing is going on. Anyone, PLEASE correct
me if this is wrong.

I think the btaudio module happily loads if there is a bttv
device present. However, it the card does not have an audio
chip like the msp3400 then there is nothing to be read from
the /dev/dsp* devices that the btaudio module creates.

Donno if this is correct. I only know that I don't have these
chips, I haven't gotten it to work and there's not much
documentation on how it's supposed to work.

--  bjm

bttv0: Hauppauge eeprom: model=62471, tuner=Philips FM1236 (2), radio=yes
bttv0: using tuner=2
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found