[mythtv] compile/install problems

Kevin Bowen mythtv-dev@snowman.net
Mon, 16 Dec 2002 10:35:27 -0800

Hmmm... actually I had already done that, but before hitting reply and
saying "i already did that" I tried it one more time. This time it worked.
Weird. In any case, I'm now having non-myth-specific problems. My tuner gets
only static, despite being (apparently) recognized properly. This is in
either myth or xawtv. The card is an Haupauge (wintv I believe?)... I'm dual
booting with windows XP, where the card works great, so I know its not a
hardware or cable connection problem.

-----Original Message-----
From: mythtv-dev-admin@snowman.net
[mailto:mythtv-dev-admin@snowman.net]On Behalf Of Brent Norris
Sent: Sunday, December 15, 2002 6:52 PM
To: MythTv
Subject: Re: [mythtv] compile/install problems

> get to section 9.2 'running setup' - first off, I'm not sure whether
> there is supposed to be a /setup directory under
> /user/local/share/mythtv - the only /setup I can find is in the
> extracted source directory... when I run the setup there, I get:
> ./setup: error while loading shared libraries: libmyth-0.7.so.0: cannot
> open shared object file: No such file or directory

That is the setup that it is talking about.  Your problem is that you
didn't add /usr/local/lib to /etc/ld.so.conf and rerun ldconfig.  Try
that out and I think it should work for you.

> the compile of myth itself generates lots of warnings, and I'm not sure
> if they're normal or if the source of the problem. Most of the warnings
> are the following:
> cc1: warning: changing search order for system directory
> "/usr/local/include"
> cc1: warning:   as it has already been specified as a non-system
> directory

Yeah I think those are standard, though I am not sure why they are
generated, but they are for me as well.

Brent Norris <brent@linux.wku.edu>

mythtv-dev mailing list