[mythtv] compile/install problems

Kevin Bowen mythtv-dev@snowman.net
15 Dec 2002 18:37:07 -0800

I'm having trouble getting myth compiled and installed for the first
time. Not sure if this list is appropriate for these type of questions,
if not, apologies in advance. I'm installing on rh8.0 and doing my best
to follow the step by step directions in the docs on the website. When I
get to section 9.2 'running setup' - first off, I'm not sure whether
there is supposed to be a /setup directory under
/user/local/share/mythtv - the only /setup I can find is in the
extracted source directory... when I run the setup there, I get:
./setup: error while loading shared libraries: libmyth-0.7.so.0: cannot
open shared object file: No such file or directory

the compile of myth itself generates lots of warnings, and I'm not sure
if they're normal or if the source of the problem. Most of the warnings
are the following:

cc1: warning: changing search order for system directory
cc1: warning:   as it has already been specified as a non-system

I notice that prior to this the doc says in section 4 "There are some
paths that need to be modified before starting the main compile of
mythtv, otherwise you will get errors." but then doesn't seem to go on
to say what path changes need to be made. I tried setting my path to
what is specified in the "Checking that it worked" section, i.e.
but this didn't seem to help.

I installed all the xmltv-related packages from rpm... I had some
dependency problems, but I think i got them all resolved. Could this be
the source of the problem?

Thanks in advance for any help anyone can give me

Kevin Bowen