[mythtv] problems with latest cvs

Bruce Markey mythtv-dev@snowman.net
Sat, 14 Dec 2002 21:23:04 -0800


Larry Matter wrote:
> Hi,
> 
> After much success with 0.7, I decided to try the latest cvs today.  It
> built fine with no compile errors (I'm using Mandrake 9).
> 
> I saw a comment somewhere that mythbackend defaults to "localhost" but
> this does not appear to be correct; it seems to default to 192.168.1.101. 
> Since I was playing locally I assumed I could get away with not changeing
> backend settings, but I was wrong.  mythbackend would segfault when I
> tried to watch live tv; so one more for the faq - change the backend
> settings no matter what.
> 
> Now live tv works, but the cpu utilization is *way* up.  I used to run
> myth at about 40-50% cpu.  Now it is running at about 70%.  What are my
> settings?  Dunno.  It seems that they are now in the database (which is
> good) but I can't get to them from the settings module.  I can get into
> General settings, but there are no buttons on the bottom for "Finish" or
> "Cancel" like there are for other screens so I can't save any changes
> there.
> 
> So I guess I can change them with SQL?  That's fine for now - if someone
> could tell me which tables/columns need to be updated that would save me
> some time reverse engineering.

There are new tables that need to be created for the
settings data. In the source tree, "cd database" then
"mysql -u mythtv -p mythconverg < 0-7-to-0-8.sql".
Start mythfrontend and go to Setup->Recording to create
a profile. For now, only the first profile you create will
be used (select * from codecparams where profile = 1;).

Hope that helps,

--  bjm