[mythtv] performance

Harondel J. Sibble mythtv-dev@snowman.net
Fri, 13 Dec 2002 23:51:18 -0800


On 13 Dec 2002 at 17:28, Ray wrote:


> ide driver in kernel etc) but there also seem to be a number of "mystry
> systems" on this list that just arn't performing as well as they should. 

I've got one of those, watching live tv with rtjpeg causes 80-90% cpu usage 
on an Athlon XP1800+ on a VIA KT133a motherboard (Epox 8kta3Pro) with 384mb 
of PC133 and a Seagate 20gb (primary - os) and Western Digital 40gb 
(secondary - myth storage only) ata100 drive.

# hdparm -tT /dev/hda

/dev/hda:
 Timing buffer-cache reads:   128 MB in  0.64 seconds =200.00 MB/sec
 Timing buffered disk reads:  64 MB in  1.61 seconds = 39.75 MB/sec

# hdparm -tT /dev/hdb

/dev/hdb:
 Timing buffer-cache reads:   128 MB in  0.64 seconds =200.00 MB/sec
 Timing buffered disk reads:  64 MB in  1.40 seconds = 45.71 MB/sec


> issue) and start looking for patterns.  It would also help to collect data on
> the cpu usage during JUST record and JUST playback and compare with similar
> systems that seem to be working correctly.  It could be a particular sound

Watching a recording gives me 15-25% CPU usage.

Using Mpeg4 results in video that is jerky (at least at a visual quality that 
is acceptable to me)


-- 
Harondel J. Sibble 
Sibble Computer Consulting
Creating solutions for the small business and home computer user.
help@pdscc.com (use pgp keyid 0x3AD5C11D) http://www.pdscc.com
(604) 739-3709 (voice/fax)      (604) 686-2253 (pager)