[mythtv] lock up thought - gcc 3.x to blame???

mythtv-dev@snowman.net mythtv-dev@snowman.net
Sat, 7 Dec 2002 18:37:24 -0800

Hey here's a thought -
    After going thru the mythtv mailing list archive reading about
other people experiencing the exact same lockup problem as myself...
could it possibly be gcc 3.x???
    I saw someone downgraded from Mandrake 9.0 -> 8.2 & then it worked -
well a major change was the inclusion of gcc 3.2 in 9.0 (the kernel
change from 2.4.18 -> 2.4.19 doesn't seem to be as big of a deal
although I'm gonna try 2.4.18 & see what happens - am currently running
2.4.20 & have tried 2.4.19 to no avail) - & since the problem seems to be thread releated I'm wondering if pthreads and/or the new gcc is to blame...
    Anyone compile their entire system using gcc 3.2 & have mythtv working???
    I'm using gentoo 1.4rc1 myself & _everything_ was compiled using gcc
3.2 & it locks up like nobody's business....

Mark Ethan Trostler	mark@zzo.com
Computing Solutions	http://www.zzo.com