[mythtv-commits] Ticket #12519: No longer functioning "mythfilldatabase"

MythTV noreply at mythtv.org
Mon Oct 5 18:58:19 UTC 2015


#12519: No longer functioning "mythfilldatabase"
-------------------------------------------+-------------------------
     Reporter:  bmlong137@…                |      Owner:  stuartm
         Type:  Bug Report - General       |     Status:  new
     Priority:  major                      |  Milestone:  0.28
    Component:  MythTV - Mythfilldatabase  |    Version:  Master Head
     Severity:  high                       |   Keywords:
Ticket locked:  0                          |
-------------------------------------------+-------------------------
 Because of an issue with a couple channels, I cleared out my "channel",
 "program", and related tables.  Now when I run "mythfilldatabase" it
 effectively does nothing.  This means my installation is completely shot.

 So I downloaded the DD XML using tv_grab_na_dd, stripped out everything
 but the "station" and "lineup" elements.  I ran mythfilldatabase with full
 debug and found the following.  This happened after both "dd_station" and
 "dd_lineupmap" were populated:

 2015-10-05 14:44:26.115590 I  MSqlQuery::exec(DBManager1) SELECT sourceid
 FROM videosource WHERE lineupid = 'NJ67209:X' <<<< Took 0ms, Returned 1
 row(s)
 2015-10-05 14:44:26.115624 I  DataDirect: sourceid 8 has lineup type:
 CableDigital
 2015-10-05 14:44:26.115859 I  MSqlQuery::exec(DataDirectCon) INSERT INTO
 dd_lineup      ( lineupid,  name,  type,  device,  postal) VALUES
 ('NJ67209:X', 'Verizon Fios Basking Ridge', 'CableDigital', 'Digital',
 '07079') <<<< Took 0ms
 2015-10-05 14:44:26.116000 I  Grab complete.  Actual data from
 2015-10-05T04:00:01Z to 2015-10-19T04:00:01Z (UTC)
 2015-10-05 14:44:26.116392 I  MSqlQuery::exec(DBManager1) DELETE FROM
 settings WHERE value = 'mythfilldatabaseLastRunEnd' AND hostname is NULL;
 <<<< Took 0ms
 2015-10-05 14:44:26.116607 I  MSqlQuery::exec(DBManager1) INSERT INTO
 settings (value,data ) VALUES ( 'mythfilldatabaseLastRunEnd',
 '2015-10-05T18:44:26Z' ); <<<< Took 0ms
 2015-10-05 14:44:26.116632 I  Main temp tables populated.
 2015-10-05 14:44:26.116635 I  Updating MythTV channels.
 2015-10-05 14:44:26.117184 I  MSqlQuery::exec(DataDirectCon) TRUNCATE
 TABLE dd_v_station;
 2015-10-05 14:44:26.118541 I  MSqlQuery::exec(DataDirectCon) INSERT INTO
 dd_v_station      ( stationid,            callsign,         stationname,
 affiliate,            fccchannelnumber, channel,            channelMinor)
 SELECT dd_station.stationid, callsign,         stationname,
 affiliate,            fccchannelnumber, channel,            channelMinor
 FROM dd_station, dd_lineupmap WHERE ((dd_station.stationid  =
 dd_lineupmap.stationid) AND        (dd_lineupmap.lineupid = '0')) <<<<
 Took 1ms

 Why is "dd_lineupmap.lineupid='0'" a constraint?  You can see a few line
 earlier the lineupid is not '0'.  I suspect the issue is here...  I assume
 this has to do with the merging of "cardinput" into "capturecard".

 Brian

--
Ticket URL: <https://code.mythtv.org/trac/ticket/12519>
MythTV <http://www.mythtv.org>
MythTV Media Center


More information about the mythtv-commits mailing list