[mythtv-commits] Ticket #12398: Livetv dvb-t subtitle autoload problem

MythTV noreply at mythtv.org
Sun Mar 29 17:07:55 UTC 2015


#12398: Livetv dvb-t subtitle autoload problem
-------------------------------------+--------------------------
 Reporter:  ismota@…                 |          Owner:  stichnot
     Type:  Bug Report - General     |         Status:  accepted
 Priority:  minor                    |      Milestone:  unknown
Component:  MythTV - Video Playback  |        Version:  0.27.4
 Severity:  medium                   |     Resolution:
 Keywords:                           |  Ticket locked:  0
-------------------------------------+--------------------------
Changes (by stichnot):

 * owner:   => stichnot
 * status:  new => accepted
 * component:  MythTV - General => MythTV - Video Playback


Comment:

 I've seen this problem for a while, but on playback of already-recorded
 programs.  Specifically, when starting playback, captions may not display
 until manually selected.

 I suspect this is related to some relatively recent improvements in
 buffering and playback startup latency.  With a smaller buffer, it's more
 likely that subtitle info isn't found until after playback actually
 starts.  When it is eventually encountered, it's added to the OSD playback
 menu but the default decision has already been made.

 I think the way to approach this to auto-upgrade to a "better" subtitle
 track whenever new tracks are discovered, unless the user has explicitly
 chosen some track.

--
Ticket URL: <https://code.mythtv.org/trac/ticket/12398#comment:1>
MythTV <http://www.mythtv.org>
MythTV Media Center


More information about the mythtv-commits mailing list