[mythtv-commits] Ticket #10801: Video screenshot images don't load under certain conditions

MythTV noreply at mythtv.org
Tue Jun 5 12:40:55 UTC 2012

#10801: Video screenshot images don't load under certain conditions
 Reporter:  josh@…      |           Type:  Bug Report - General
   Status:  new         |       Priority:  minor
Milestone:  0.25.1      |      Component:  MythTV - Video Library
  Version:  0.25-fixes  |       Severity:  medium
 Keywords:              |  Ticket locked:  0
 When using storage groups for all video info (Videos themselves as well as
 meta images), individual episode screenshots do not load under certain
 conditions and the season cover art is shown instead.

 Required conditions:
 * Remote frontend (ie screenshot directory is not locally accessible)
 * Video file that has screenshot and where file is not located in a top
 level directory (See below for further info)
 * View mode: Browse Library, Show Directory Structure

 With the above conditions, if the file is located 1 directory level down
 from the Storage Group root, the screenshot loads OK. If it is more than 1
 level down, the cover image is loaded, not the screenshot.
 Storage group: /video/
 File 1: /video/MyShow/episode1.avi <--- Works
 File 2: /video/MyShow/season 1/episode1.avi <--- Doesn't work

 Note that if you do the same test on the machine where the screenshot
 files are actually located (Eg combined backend/frontend) everything works
 OK. It is only when on a remote frontend that this occurs.

Ticket URL: <http://code.mythtv.org/trac/ticket/10801>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center

More information about the mythtv-commits mailing list