[mythtv-commits] Ticket #10800: Inaccurate mythtranscode cuts

MythTV noreply at mythtv.org
Mon Jun 4 21:23:33 UTC 2012

#10800: Inaccurate mythtranscode cuts
 Reporter:  im.js@…     |           Type:  Bug Report - General
   Status:  new         |       Priority:  minor
Milestone:  unknown     |      Component:  MythTV - Mythtranscode
  Version:  0.25-fixes  |       Severity:  medium
 Keywords:              |  Ticket locked:  0
 When using mythtranscode --honorcutlist to remove commercials, the
 resulting cuts are not accurate to the cuts specified in the cut list.

 I am trying to remove commercials from 1080i recordings by marking the
 cuts in Mythtv and running the default transcode profile configured for
 lossless output.

 The actual cuts are off mark by different amounts, sometimes over 2
 seconds from the intended cut point.

 I am running mythtv 0.25 on a fresh install of mythbuntu 12.04.

 This method of cutting commercials worked with frame-level accuracy in
 previous versions of mythtv, but it appears to be broken now.

 The cuts seem to be set accurately when playing back the recording with
 the frontend.

 I have tried re-building the keyframe index prior to setting cut points
 and transcoding, but that made no difference.  I also tried multiple
 different 1080i TV sources, with no improvement.

 I really miss this feature, and would be happy to diagnose further,
 provide logs, or whatever.

Ticket URL: <http://code.mythtv.org/trac/ticket/10800>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center

More information about the mythtv-commits mailing list