[mythtv-commits] Ticket #10583: Unable to playback recordings from Panasonic TV via UPnP

MythTV noreply at mythtv.org
Thu Apr 12 09:59:31 UTC 2012

#10583: Unable to playback recordings from Panasonic TV via UPnP
     Reporter:  joe@…                 |      Owner:  dblain
         Type:  Bug Report - General  |     Status:  new
     Priority:  minor                 |  Milestone:  unknown
    Component:  MythTV - UPnP         |    Version:  0.25-fixes
     Severity:  low                   |   Keywords:  UPNP DLNA TV
Ticket locked:  0                     |
 I am unable to playback recorded shows from MythTV on a Panasonic TX-
 P42G15GB TV via UPnP. I simply get the error message on the TV: "Cannot
 read file"

 If I manually copy the recorded shows to the videos storage group, the TV
 plays the show back with no problem whatsoever. This leads me to believe
 that when the recording file is served to the TV in the Recordings storage
 group, something different is happening in the UPnP code, meaning that the
 TV is unable to read the file.

 Other UPnP clients such as XBMC and VLC can playback the recordings ok, no
 matter what type of storage group the recording is in, so it's not a
 widespread problem, just specific to the TV we have/Panasonic TVs in
 general - this is the only Panasonic TV in the house, so I can't say which
 for sure.

 No errors are showing up in the backend log (with -v all) and
 unfortunately the error message above is all I've got from the TV.

 I've tried to work this one our for myself, but I'm unable to find any
 more information from logs why this is happening. I'm not a developer, but
 I do work for a software development company, so I have gained *some*
 experience working with code. I've therefore tried to have a look into the
 UPnP code myself, just to try to find some sort of direction to go with
 this, however I wasn't able to spot anything.

 I would appreciate any help I can get on this - at the moment, I'm working
 around the issue by manually moving recording files from the Recordings
 storage group to the Videos one, every time someone wants to watch
 something that's been recorded. This is becoming a bit of chore - don;t
 mean to sound ungrateful though!

 Attached files:
 not-working.mythbackend.log: Log file taken when trying to playback a
 recording as a "Recording" on the TV. (mythbackend -v all)
 working.mythbackend.log: Log file taken when successfully playing a
 recording as a "Video" on the TV. (mythbackend -v all)

 If there's any more info needed, I'll be more than happy to provide it.
 I'm wondering if there's some way I can get more output from what the
 backend is actually sending to the TV, then diffing the output between a
 "Recording" and a "Video"?

 Thank you.


Ticket URL: <http://code.mythtv.org/trac/ticket/10583>
MythTV <http://code.mythtv.org/trac>
MythTV Media Center

More information about the mythtv-commits mailing list