[mythtv-commits] Ticket #8848: Realtime commercial detection fails for some QAM channels

MythTV mythtv at cvs.mythtv.org
Tue Sep 14 03:34:44 UTC 2010

#8848: Realtime commercial detection fails for some QAM channels
 Reporter:  dlinvill@…             |           Owner:  cpinkham  
     Type:  defect                 |          Status:  infoneeded
 Priority:  minor                  |       Milestone:  0.24      
Component:  MythTV - Mythcommflag  |         Version:  Trunk Head
 Severity:  medium                 |      Resolution:            
 Keywords:  commflag commercial    |   Ticket locked:  0         

Comment (by cpinkham):

 OK, that log was helpful.  It's trying to seek past the known positionmap
 and going into frame-by-frame seek mode.  It could be getting stuck here
 somehow when run ~realtime.  When you ran mythcommflag externally, it did
 get past the first logo detection loop run and go into the second run
 before you hit CTRL-C, so the symptoms weren't quite the same as before
 but it was informative.

 Can you re-create the scenario one more time, and this time, run the
 backend with
 "-v extra,commflag,playback,database,record,network"

 You don't need to do the gdb session this time, just run the backend,
 schedule a recording.  Wait until the backend logs show the "Searching for
 Logo" message and then wait another couple minutes and that should be
 enough info I think.

 Also, I see this tried to use the LiveTV Storage Group, was this LiveTV or
 a recording that you assigned to the LiveTV storage group?

 I don't know if the recorder isn't writing out the seektable often enough
 or if the player isn't getting the data.  The new log should help
 determine this.

Ticket URL: <http://svn.mythtv.org/trac/ticket/8848#comment:6>
MythTV <http://www.mythtv.org/>
MythTV Media Center

More information about the mythtv-commits mailing list