[mythtv-commits] Ticket #8201: Mythtv requesting wrong decoder profile from VDPAU

MythTV mythtv at cvs.mythtv.org
Sat Mar 20 08:12:04 UTC 2010

#8201: Mythtv requesting wrong decoder profile from VDPAU
 Reporter:  Per  <heldal@…>          |       Owner:  janne  
     Type:  defect                   |      Status:  new    
 Priority:  minor                    |   Milestone:  unknown
Component:  MythTV - Video Playback  |     Version:  head   
 Severity:  medium                   |     Mlocked:  0      

Comment(by Per Heldal <heldal@…>):

 I did not intially notice that the CPU-load doesn't increase while
 watching recordings from the troublesome channel. That indicates that the
 decoding is still handled in hardware and not falling back to use
 libavformat as previously assumed. The issue may not be VDPAU-related at
 all, but rather something else to do with A/V sync. I don't have a machine
 that is powerful enough to test software decoding of HD-streams to confirm
 this. Using VDPAU the frontend is reporting that it is dropping frames
 because video lags behind audio.

 Also worth mentioning is that the problem with this channel has existed in
 mythtv/trunk for a few months. It was ok some time ago, but I'm unable to
 trace it back to a particular changeset in myth code or relate it to a
 change in the operators encoding of the channel.

Ticket URL: <http://svn.mythtv.org/trac/ticket/8201#comment:2>
MythTV <http://www.mythtv.org/>

More information about the mythtv-commits mailing list