[mythtv-commits] Ticket #7893: mythcommflag segfaults and finds 0 commercials

MythTV mythtv at cvs.mythtv.org
Wed Jan 20 05:07:10 UTC 2010

#7893: mythcommflag segfaults and finds 0 commercials
 Reporter:  Ronald Frazier <ron@…>               |       Owner:  cpinkham      
     Type:  defect                               |      Status:  infoneeded_new
 Priority:  minor                                |   Milestone:  unknown       
Component:  MythTV - Mythcommflag                |     Version:  unknown       
 Severity:  medium                               |     Mlocked:  0             

Comment(by Ronald Frazier <ron@…>):

 I tried posting the following on the dev forum (as I thought discussion
 was discouraged in trac), but nobody has given an answer in over a week,
 so I'm posting here:

 What do you mean, exactly? What is missing? As far as I can tell, I've
 followed the instructions here:

 I did a make distclean, ran configure with --compile-type=debug, then
 a make and make install, made sure everything was stopped, then
 restarted the backend. I just double checked my command history and
 that is indeed what I did.

 I set it to dump a core. I ran the core through gdb and generated the
 backtrace. If you look in the first log, you can see that there is
 debug info for myth with line numbers. Why the 2nd and 3rd logs have
 so little info in it, I have no idea, but I followed the same
 instructions I used to generate the first log. I didn't think you'd
 need the dozens of

 Reading symbols from /usr/local/lib/libmythtv-0.22.so.0...done.[[BR]]
 Loaded symbols for /usr/local/lib/libmythtv-0.22.so.0[[BR]]
 Reading symbols from
 Loaded symbols for /usr/local/lib/libmythavformat-0.22.so.0[[BR]]

 lines, so I omitted them. If you can tell me what I did wrong, I'd be
 more than happy to retry.

Ticket URL: <http://svn.mythtv.org/trac/ticket/7893#comment:2>
MythTV <http://www.mythtv.org/>

More information about the mythtv-commits mailing list