[mythtv-commits] Ticket #8361: ALSA audio capture doesn't work with snd-bt87x driver [PATCH INCLUDED]

MythTV mythtv at cvs.mythtv.org
Tue Apr 20 18:26:19 UTC 2010

#8361: ALSA audio capture doesn't work with snd-bt87x driver [PATCH INCLUDED]
 Reporter:  Carlos Azevedo <geral@…>             |       Owner:  danielk
     Type:  defect                               |      Status:  new    
 Priority:  minor                                |   Milestone:  unknown
Component:  MythTV - Recording                   |     Version:  0.23rc2
 Severity:  low                                  |     Mlocked:  0      

Comment(by Carlos Azevedo <geral@…>):

 As requested via IRC, I'm adding a quote from
 http://www.mythtv.org/wiki/ALSA,_BTTV_and_MythTV_0.22, which a wrote at
 the time:

 "Everytime I tried to use the board for capture MythTV would error out
 about not being able to set the sample rate (wanted 48000, the driver
 reported 119466 sp/s), not being able to set the number of channels
 (wanted two, the driver only reported one) and some other errors"

 I never got around to debugging the interaction of the MythTv's
 initialization code with ALSA, I simply looked at the code for arecord
 that does the same initialization in a much simplified mannor, plugged it
 in and it worked. I don't understand why the current code does it in such
 a roundabout way, but my way does work, and should work with all BTTV-
 based setups. Setups with others kinds of capture cards may require that
 kind of initialization but I doubt it.

 P.S. This patch has to be applied inside libs/libmythtv

Ticket URL: <http://svn.mythtv.org/trac/ticket/8361#comment:2>
MythTV <http://www.mythtv.org/>

More information about the mythtv-commits mailing list