[mythtv-commits] Ticket #6624: VLD XvMC broken in 0.21-fixes

MythTV mythtv at cvs.mythtv.org
Thu Jun 11 20:37:52 UTC 2009

#6624: VLD XvMC broken in 0.21-fixes
 Reporter:  rhp at dse.nl               |       Owner:  ijr       
     Type:  defect                   |      Status:  new       
 Priority:  minor                    |   Milestone:  unknown   
Component:  MythTV - Video Playback  |     Version:  0.21-fixes
 Severity:  medium                   |     Mlocked:  0         
 MythTV Version   : 0.21-18.md10 (own compilation of release-0.21-fixes,
 version 20666)
 MythTV Branch    : tags/release-0-21
 Library API      : 0.21.20080304-1
 Network Protocol : 40
 Options compiled in:
  linux release using_oss using_alsa using_pulse using_arts using_jack
 using_backend using_dbox2 using_dvb using_firewire using_frontend
 using_hdhomerun using_iptv using_ivtv using_joystick_menu using_lirc
 using_opengl_vsync using_v4l using_x11 using_xrandr using_xv using_xvmc
 using_xvmcw using_xvmc_vld using_bindings_perl using_bindings_python
 using_opengl using_ffmpeg_threads using_libavc_5_3 using_live

 After upgrading from MythDora 4.0 (release-0.20-fixes) to MythDora 10.21,
 playback is at very stuttery or at 100% CPU. Before upgrading things were
 much more smooth and CPU usage was around 40-45%.
 Using xine to play the same file runs at 20% CPU without any problems.
 I've already patched openchrome to see which calls were made on XvMC
 level. Though I see some differences between xine and mythtv, the calls
 are mostly the same, which would seem to suggest that mythtv _is_ using

 I'm running a VIA EPIA M1000 with CLE266.

 Ronald Pijnacker

Ticket URL: <http://svn.mythtv.org/trac/ticket/6624>
MythTV <http://www.mythtv.org/>

More information about the mythtv-commits mailing list