[mythtv-commits] Ticket #6443: Transcode job doesn't exit

MythTV mythtv at cvs.mythtv.org
Thu Apr 9 06:28:38 UTC 2009

#6443: Transcode job doesn't exit
 Reporter:  paul [at] planar.id.au  |       Owner:  ijr    
     Type:  defect                  |      Status:  new    
 Priority:  minor                   |   Milestone:  unknown
Component:  MythTV - Mythtranscode  |     Version:  unknown
 Severity:  low                     |     Mlocked:  0      
 I'm running trunk, latest version ().

 I noticed the other day that I had a large number of mythtranscode jobs
 running on my machine - 20 or 30 of them. They were all idle, and of
 various ages. I killed them all, and upgraded to the latest version to see
 if it still was doing it. Yesterday morning I again had a couple of spare

 I was trying to work out how to debug this. I used ps -efl to get the full
 command line, and then ran that job with the extra "-v most" option, and
 output stdout and stderr to a log.

 The command I ran was:
 /usr/bin/mythtranscode -j 5217 -V 3 -p 28 -v most > transcode_log 2>&1

 The end of that log shows what appears to be a clean exit (refer bottom of
 this message for last 20 lines of the log) and the command from my command
 line claims to have ended:
 [1]+ Done /usr/bin/mythtranscode -j 5217 -V 3 -p 28
 -v most > transcode_log 2>&1

 However, when I run
   ps -ef |grep transcode

 I still see the job running:
 mythtv 1179 1 0 07:10 pts/8 00:00:00 /usr/bin/mythtranscode
 -j 5217 -V 3 -p 28 -v most

 This seems very weird to me - that linux would think the job has ended
 when it is still there. It sort of seems like it would most likely be some
 sort of user error on my part, but I can't imagine what I would have done
 that would cause it. It wasn't happening a month or so ago, and is
 happening now, and I don't recall changing any material settings in that

 Extract last 20 lines of log:
 2009-04-02 07:10:39.595 read <- 10 51
 2009-04-02 07:10:39.603 MythEvent: RECORDING_LIST_CHANGE
 2009-04-02 07:10:39.617 JobQueue: ChangeJobStatus(5217, Stopping, '')
 2009-04-02 07:10:39.617 Transcoding
 /usr/share/mythtv/recordings/6008_20090330112000.nuv done
 2009-04-02 07:10:39.653 SG(Default): FindRecordingFile: Searching for
 2009-04-02 07:10:39.653 SG(Default): FindRecordingDir: Checking
 '/usr/share/mythtv/recordings' for
 2009-04-02 07:10:39.653 SG(Default): FindRecordingFile: Found
 2009-04-02 07:10:39.653 ProgramInfo: GetPlaybackURL: File is local:
 2009-04-02 07:10:39.751 mythtranscode: About to unlink/delete file:
 2009-04-02 07:10:39.767 Truncating
 2009-04-02 07:10:39.769 Truncating
 /usr/share/mythtv/recordings/6008_20090330112000.nuv.old in the
 2009-04-02 07:10:40.205 JobQueue: ChangeJobStatus(5217, Finished, '')
 2009-04-02 07:10:40.206 MythSocket(8f3ad40:11): DownRef: -1
 2009-04-02 07:10:40.206 MythSocket(8f3ad40:11): state change Connected ->
 2009-04-02 07:10:40.206 MythSocket(8f3ad40:-1): delete socket
 2009-04-02 07:10:40.206 MythSocket(8f3c798:10): DownRef: 0
 2009-04-02 07:10:40.232 MythSocket(8f3c798:10): DownRef: -1
 2009-04-02 07:10:40.232 MythSocket(8f3c798:10): state change Connected ->
 2009-04-02 07:10:40.232 MythSocket(8f3c798:-1): delete socket
 2009-04-02 07:10:40.489 MythSocket: readyread thread exit

Ticket URL: <http://svn.mythtv.org/trac/ticket/6443>
MythTV <http://www.mythtv.org/>

More information about the mythtv-commits mailing list