[mythtv-commits] Ticket #6036: Xlib: unexpected async reply (sequence 0x2b)!

MythTV mythtv at cvs.mythtv.org
Mon Dec 29 18:44:52 UTC 2008

#6036: Xlib: unexpected async reply (sequence 0x2b)!
 Reporter:  Ben Dailey <ben at inspiredtechs.com>  |       Owner:  ijr    
     Type:  defect                              |      Status:  new    
 Priority:  major                               |   Milestone:  unknown
Component:  mythtv                              |     Version:  head   
 Severity:  medium                              |     Mlocked:  0      
 After the mythtv-vid merge r19417 playing back almost all recording causes
 the front end to hang with error: Xlib: unexpected async reply (sequence
 0x2b)! from my research this is a threading issue. r19416 does not
 demonstrate this issue. If I run mythfrontend under gdb the lock up does
 not occur also running with "-v all" seems to cause the issue not occur as
 well. Command run is "exec /usr/bin/mythfrontend -l
 /var/log/mythtv/frontend.log -v important,general,playback,libav"

 MythTV Version   : 19417M[[BR]]
 MythTV Branch    : trunk[[BR]]
 Library API      : 0.22.20081222-1[[BR]]
 Network Protocol : 43[[BR]]
 QT Version       : 4.4.2[[BR]]
 Options compiled in:[[BR]]
  linux debug using_alsa using_backend using_dvb using_frontend using_mheg
 using_opengl_video using_opengl_vsync using_qtwebkit using_x11
 using_xrandr using_xv using_xvmc using_xvmc_opengl using_bindings_perl
 using_bindings_python using_opengl using_ffmpeg_threads using_mheg

 Attached: configure output, frontend log, and gdbcommands files I tried to
 use for debug. Please let me know how I can help or what other information
 would be helpful.

Ticket URL: <http://svn.mythtv.org/trac/ticket/6036>
MythTV <http://www.mythtv.org/>

More information about the mythtv-commits mailing list