[mythtv-commits] Ticket #4025: DVD Eject not working properly

MythTV mythtv at cvs.mythtv.org
Fri Sep 28 16:21:03 UTC 2007

#4025: DVD Eject not working properly
 Reporter:  skd5aner at gmail.com  |       Owner:  ijr    
     Type:  defect              |      Status:  new    
 Priority:  minor               |   Milestone:  unknown
Component:  mythtv              |     Version:  head   
 Severity:  medium              |     Mlocked:  0      
 I'm running current SVN (r14526) and over the past summer I've seen a
 regression in ejecting my DVD drive.

 1) I used to be able to open and close the DVD drive manually via the
 physical button on the dvd drive.  I lost that functionality a few months
 2) I then used to be able to use the "eject media" option in myth with no

 Now, I can no longer manually use the eject button and the eject option
 within mythfrontend isn't working properly.  What happens is when
 mythfrontend first starts up, the physical eject button no longer works.
 It works during boot and when mythfrontend is not running.  In addition,
 when I use mythfrontend to eject the media, it'll work maybe 2 or 3 times.
 Then it no longer ejects the drive.  I get the following:

 "Unable to open orclose the empty drive LITE-ON DVDRW SHW-160P6S
 (/dev/scd0).  You may have to use the eject button on the drive".
 However, like I've said, it's like myth locks the utilization of the
 physical eject button.  If the frontend isn't running, it works just fine.
 When I use the "eject media" options, it'll turn on the LCD light on the
 drive, spin it up for about a second, and then the message comes up.

 The only way I can ever get the tray to eject after this occurs is by

 Please let me know if there's any more information I can provide to help
 fix this.

Ticket URL: <http://svn.mythtv.org/trac/ticket/4025>
MythTV <http://svn.mythtv.org/trac>

More information about the mythtv-commits mailing list