[mythtv-commits] Ticket #4044: OSD fonts badly rendered on a 16:9 HDTV

MythTV mythtv at cvs.mythtv.org
Wed Oct 3 19:42:35 UTC 2007

#4044: OSD fonts badly rendered on a 16:9 HDTV
 Reporter:  anonymous  |        Owner:  ijr     
     Type:  defect     |       Status:  reopened
 Priority:  minor      |    Milestone:  unknown 
Component:  mythtv     |      Version:  0.20.2  
 Severity:  high       |   Resolution:          
  Mlocked:  0          |  
Changes (by nico at youplala.net):

  * status:  closed => reopened
  * resolution:  invalid =>



 Friendly place, here.

 OK, I decided not to be too offended by the abuse.

 On top of the NVIDIA way of hard-coding the DPI (yes, I did read the FAQ
 on the wiki) I have added the display size stuff.

 Section "Monitor"
         Identifier      "MonitorTMDS"
         Option          "DPMS"
         Option          "UseEdidDpi"            "FALSE"
         Option          "DPI"                   "100 x 100"
         # For 1920x1080 at 100dpi  (16:9)
         DisplaySize  487 274

 I kick gdm in order to restart X.

 I check, same bad rendering for the OSD. No mention of DisplaySize in
 the X logs. I still get the normal NVIDIA stuff:

 (**) NVIDIA(0): DPI set to (100, 100); computed from "DPI" X config

 So why not remove the NVIDIA-specific stuff, and only leave the
 displaysize statement?

 Section "Monitor"
         Identifier      "MonitorTMDS"
         Option          "DPMS"
         # For 1920x1080 at 100dpi  (16:9)
         DisplaySize     487 274
 #       Option          "UseEdidDpi"            "FALSE"
 #       Option          "DPI"                   "100 x 100"

 I swiftly do that and restart X.

 The menus have very small fonts now. But the OSD is still badly

 I check the X logs and still get no mention of DisplaySize.

 But instead I get this:

 (--) NVIDIA(0): DPI set to (46, 46); computed from "UseEdidDpi" X config

 DisplaySize is apparently not a valid entry for the NVIDIA driver...

 But rest assured that DisplaySize was a valid entry when I was using the
 on-board Intel GPU. I had tried it a few months ago, and still it did
 not fix my OSD text rendering issues. I do read wikis and mailing list
 archives. I do use Google too.

 So it sounds like I'm not such a complete moron after all and that
 closing the ticket may have been done slightly too early.

 So, what's your take on what I still think is a bug?


Ticket URL: <http://svn.mythtv.org/trac/ticket/4044#comment:2>
MythTV <http://svn.mythtv.org/trac>

More information about the mythtv-commits mailing list