[mythtv-commits] Ticket #3451: Mythgame 100% cpu

MythTV mythtv at cvs.mythtv.org
Sat May 12 00:13:43 UTC 2007

#3451: Mythgame 100% cpu
 Reporter:  anonymous  |       Owner:  ijr    
     Type:  defect     |      Status:  new    
 Priority:  minor      |   Milestone:  unknown
Component:  mythtv     |     Version:  unknown
 Severity:  medium     |  
 I'm having a problem with Mythgame (possibly Mythtv) and executing
 emulators. I can browse to a rom, execute it and the appropriate emulator
 will start however CPU usage on the emulator process will immediately jump
 to 100% and the emulator will run extremely slowly. This is occuring for
 emulators zsnes, xmame and mupen64. I would guess the same problem would
 occurs with other emulators however I've not tried further.
 Each of these emulators will run perfectly if Mythtv is not running. I'm
 not sure the problem is with mythGame itself however, as if I run
 mythfrontend, then execute an emulator from outside of it (ie from a
 separate prompt) the same problem occurs. Interestingly, if the emulator
 is already running when Mythtv is started it is the mythfrontend process
 that goes to 100% cpu.

 If I run mythfrontend with -v all I see the following line just before
 zsnes (Or other emulator) loads:
 "MythThemedDialog.o: something is requesting a screen update of zero size.
 A widget probably has not done a calculateScreeArea(). Will redraw the
 whole screen (inefficient!)."

 and I'm wondering whether something like this might be causing a problem.

 2.8 P4 (Hyperthreading disabled)
 MythGame 0.20a (although the same problem occurs with the svn version too)
 Ubuntu Feisty
 Nvidia 6200 (Driver version 9629)

 The fact that this is occuring for multiple emulators makes me think that
 this is a bug with Myth  rather than the emulators themselves.

Ticket URL: <http://svn.mythtv.org/trac/ticket/3451>
MythTV <http://svn.mythtv.org/trac>

More information about the mythtv-commits mailing list