[mythtv-commits] Ticket #3715: osx-packager.pl no longer builds mythtv configure script reports that threaded Qt must be installed

MythTV mythtv at cvs.mythtv.org
Tue Jul 10 18:26:35 UTC 2007


#3715: osx-packager.pl no longer builds mythtv configure script reports that
threaded Qt must be installed
-----------------------+----------------------------------------------------
 Reporter:  anonymous  |       Owner:  ijr    
     Type:  defect     |      Status:  new    
 Priority:  minor      |   Milestone:  unknown
Component:  mythtv     |     Version:  head   
 Severity:  medium     |     Mlocked:  0      
-----------------------+----------------------------------------------------
 About 20-30 revisions before the osx-packager.pl would have no problem
 building latest head, since the configure script was updated it will no
 longer build, the following error is seen:

 {{{
 Checked out revision 13857.
 patching file libs/libmythui/mythmainwindow.cpp
 Hunk #1 succeeded at 1092 (offset 3 lines).
 Hunk #2 succeeded at 1115 (offset 3 lines).
 DVB location needs to have linux/dvb/frontend.h
 [/usr/src/linux-8.9.1/include]
 ERROR! You must have a threaded Qt installed to compile MythTV.
 If you think configure made a mistake, make sure you are using the latest
 version from SVN.  If the latest version fails, report the problem to the
 mythtv-dev at mythtv.org mailing list or IRC #mythtv on irc.freenode.net
 Include the log file "config.err" produced by configure as this will help
 solving the problem.
 [osx-pkg] Failed system call: " ./configure --prefix=/Users/vadim/OSX
 /.osx-packager/build --disable-distcc " with error code 1
 Died at osx-packager.pl line 881.
 }}}

 It seems that the path now needs to given manually, therefore even though
 qt was compiled in /.osx-packager/src/qt-mac-free-3.3.8 the path is
 missing and it will not compile.

-- 
Ticket URL: <http://svn.mythtv.org/trac/ticket/3715>
MythTV <http://svn.mythtv.org/trac>
MythTV


More information about the mythtv-commits mailing list