[mythtv-commits] Ticket #2335: LiveTV hangs when a recording is finished and a new on starts (no channel change)

MythTV mythtv at cvs.mythtv.org
Tue Apr 3 17:43:58 UTC 2007

#2335: LiveTV hangs when a recording is finished and a new on starts (no channel
 Reporter:  tino.keitel+mythtv at tikei.de  |        Owner:  ijr     
     Type:  defect                       |       Status:  reopened
 Priority:  minor                        |    Milestone:  unknown 
Component:  mythtv                       |      Version:  head    
 Severity:  medium                       |   Resolution:          

Comment(by anonymous):

 I have been chasing this "bug/feature" for about the past 3 months now
 with Fedora 6 and MythTV .20. I tried all the tricks that I knew about
 tweaking linux, i.e. hdparm, setpci, turn off all services(yea thats
 right, I turned off everything except mysqld and lircd), and a couple of
 other things. I even tried different hardware. All to no avail. I finally
 camne across this post http://www.gossamer-
 threads.com/lists/mythtv/users/258531 where they discuss tuning mysql. I
 started with the settings below for my /etc/my.cnf file.

 key_buffer = 16M
 max_allowed_packet = 8M
 table_cache = 128
 sort_buffer_size = 16M
 net_buffer_length = 8M
 thread_cache_size = 4
 query_cache_type = 1
 query_cache_size = 4M

 This did improve the freezing slightly. It still froze during the night
 when it ran mythfilldatabase. So I did a little research on tuning mysql
 myself(there is alot of stuff to look at so I didn't really learn that
 much). However I eneded up with a /etc/my.cnf that looks like this in th
 mysqld section.

 key_buffer = 32M
 max_allowed_packet = 16M
 table_cache = 1000
 sort_buffer_size = 32M
 net_buffer_length = 16M
 thread_cache_size = 200
 query_cache_type = 1
 query_cache_size = 24M

 And since I started using these settings I have not had a single freeze up
 at any time, or any other issue for that matter. As soon as I went a day
 without a freeze I did a complete reinstall of Fedora core 6 and Mythtv
 .20 and used the new settings for mysql server. IT WORKS FLAWLESSLY :) :)
 :). By the way, I am now using a E-Machines P4 2.6 Ghz with 768 MB of ram
 and 2 PVR-150. When I first started, I was using one PVR-150 and one
 WinTV-GO. I eventully gave up on the WinTV-GO card thinking that it was
 causing some of the problem, but now that I have gone about a week and a
 half without any issues(no reboots), I'm starting to think about trying
 the WinTV-GO card again. The bottom line is that it was deffintly the
 mysql server performance that was causing this problem for me and I bet
 for alot of other people as well. I hope the developers see this and can
 help get it right in upcomming releases. If you run mythbackend with the
 "-v all" option you will see that myth is doing ALOT and I do mean ALOT of
 sql queeries for seek positions.

Ticket URL: <http://svn.mythtv.org/trac/ticket/2335#comment:33>
MythTV <http://svn.mythtv.org/trac>

More information about the mythtv-commits mailing list