[mythtv-commits] Ticket #1571: Changing channels under live TV to in-use tuner confuses the system

MythTV mythtv at cvs.mythtv.org
Thu Mar 23 05:26:35 UTC 2006

#1571: Changing channels under live TV to in-use tuner confuses the system
 Reporter:  television at cneufeld.ca  |       Owner:  ijr
     Type:  defect                  |      Status:  new
 Priority:  minor                   |   Milestone:     
Component:  mythtv                  |     Version:     
 Severity:  medium                  |  
 I have a PVR-500 and a single box which is both front end and back end.
 Both tuners have access to regular cable, but only tuner0 can tune to
 channels on the digital cable box through its RCA connection.  Tuner0 was
 recording a regular cable show, and I was in "live TV".  Not knowing which
 tuner was recording, I tried to change channels to a digital channel.
 Several things went wrong:

 - A popup appeared in the middle of the live TV telling me of the problem
 and advising me to delete the in-progress recording if I wanted to watch
 that channel[[BR]]
 - This popup could not be eliminated with ESC, Enter, the arrow keys, or
 the mouse[[BR]]
 - Several seconds later, the live TV, still behind the popup, froze[[BR]]
 - I killed off X with ctrl-alt-backspace, and restarted it[[BR]]
 - The backend now believes that I'm still watching, as live TV, the last
 channel that was tuned on tuner1 before I tried to change to the digital
 channel, but if I try to watch live TV, it tells me I have no tuners
 - A few minutes later, a second recording was scheduled to begin on
 tuner1, but it was skipped because tuner1 still believed it was trying to
 show me live TV[[BR]]

 I rebooted the machine, and the missed recording was started from the time
 of the reboot.

 This is with mythtv-0.19.  I haven't tried the svn tree.

Ticket URL: <http://svn.mythtv.org/trac/ticket/1571>
MythTV <http://www.mythtv.org/>

More information about the mythtv-commits mailing list