[mythtv-commits] Ticket #1533: Post 0.19 patches crash system when playing livetv/recordings on PVR350 TV-Out

MythTV mythtv at cvs.mythtv.org
Fri Mar 17 13:32:50 UTC 2006

#1533: Post 0.19 patches crash system when playing livetv/recordings on PVR350 TV-
 Reporter:  luud.heck at gmail.com  |       Owner:  ijr    
     Type:  defect               |      Status:  new    
 Priority:  blocker              |   Milestone:  unknown
Component:  mythtv               |     Version:  head   
 Severity:  high                 |  
 I noticed that somewhere in the post 0.19 release patches something
 changed causing my system to mess up the PCI irq kernel subsystem.

 I'm running gentoo and when I upgraded from the (now no longer available)
 mythtv-0.19-r1 ebuild to the mythtv-0.19_p9163-r1 ebuild playing any video
 on the PVR350 TV-Out would first result in terrible sound (choppy and
 hissy). Pausing and continuing would fix the sound problem, but resulted
 in crashing the IRQ subsystem resulting in my network card no longer

 So I cloned the mythtv-0.19_p9163-r1 to remove the post 0.19 patches and
 now the system is stable again. Attached is the ebuild I created for
 reference. It contains the location of the patches file used in the
 mythtv-0.19_p9163-r1 ebuild. It seems to me this relates to the revision

 System details:
 Abit BH6 motherboard
 Celeron 700
 PVR350 (PCI slot 1)
 PVR500 (PCI slot 2)
 HPT360 ATA-100 (PCI slot 3)
 Creative SB128 (PCI slot 4)
 3com 3c905 (PCI slot 5)

 Having the PVR cards first in the system is important otherwise the ivtv
 system is unstable. With mythv 0.19, this system is very stable, I've had
 it running for about 11 days.

 Note that recording is no problem, but playback of recordings or livetv is
 bad. Playback on a remote frontend on an X server is also no problem (just
 to a PC screen that is).

Ticket URL: <http://svn.mythtv.org/trac/ticket/1533>
MythTV <http://www.mythtv.org/>

More information about the mythtv-commits mailing list