[mythtv-commits] Ticket #1158: XvMC playback stutters after PAUSE/UNPAUSE using SVN 8770

MythTV mythtv at cvs.mythtv.org
Mon Jan 30 20:03:41 UTC 2006

#1158: XvMC playback stutters after PAUSE/UNPAUSE using SVN 8770
 Reporter:  tralph11 at yahoo.com  |       Owner:  ijr 
     Type:  defect              |      Status:  new 
 Priority:  minor               |   Milestone:      
Component:  mythtv              |     Version:  head
 Severity:  medium              |  
 Many of my HD recordings (AC3 5.1) seem to suffer a problem when doing a
 PAUSE/UNPAUSE during playback. A SKIP BACK _always_ clears up the problem
 and I then have smooth playback. It seems that the problem is much more
 apparent when I've got ac3 passthru enabled and use audio as timebase.

 System Specs

  - Athlon XP 2500+

  - Nvidia GeForce4 MX 440 (version 7676 drivers)

 Configuration (SVN 8770)

  - XvMC with Chromakey OSD

  - AC3 passthru

  - Extra audio buffering

  - Audio as timebase

  - Opengl vsync (same behaviour on or off)

  - Realtime priority

 I'm attaching a frontend log created with -v all. The one thing I notice
 is that it seems to continuously print the following messages until I
 perform a SKIP BACK:

 NVP: Video is 4.67542 frames ahead of audio, skipping A/V wait.

 On a side note, when trying the 8178 nvidia drivers (I turned opengl vsync
 off) a PAUSE/UNPAUSE caused a very large persistent spike in CPU usage for
 the Xorg process until I did a SKIP BACK. The 7676 drivers don't exhibit
 this problem. Not sure if this is useful information or not.

 I'm not sure what SKIP BACK (or probably any type of seek) is doing
 exactly but it seems to get playback into a proper state. Atleast I have a
 work around for now using SKIP BACK.

 Daniel, Thanks for all the hard work on XvMC. Using XvMC and the Chromakey
 OSD has made a tremendous difference on my system. For the first time I
 was able to playback high bitrate 1080i streams during live-tv with no
 stuttering at all!

 I can also make available a recording that exhibits this problem using the
 Internal player under mythvideo. Please let me know if you need anything


Ticket URL: <http://svn.mythtv.org/trac/ticket/1158>
MythTV <http://www.mythtv.org/>

More information about the mythtv-commits mailing list