[mythtv-commits] Ticket #1751: mythbackend SEGV when deleting files from mythweb

MythTV mythtv at cvs.mythtv.org
Sun Apr 30 14:34:53 UTC 2006


#1751: mythbackend SEGV when deleting files from mythweb
---------------------------------+------------------------------------------
 Reporter:  joseph at heenan.me.uk  |       Owner:  ijr
     Type:  defect               |      Status:  new
 Priority:  minor                |   Milestone:     
Component:  mythtv               |     Version:     
 Severity:  medium               |  
---------------------------------+------------------------------------------
 I can reproducabily crash mythbackend by using mythweb to delete a number
 of files in quick succession.

 Version is the latest release-0-19-fixes (rev 9806).

 mythtv is configured using:
 ./configure --compile-type=debug --prefix=/usr/local/myth --enable-dvb
 --dvb-path=/usr/src/linux-2.6.15/include --disable-joystick-menu
 --disable-dvb-eit

 The host system is a update to date debian sarge install, 2 dvb-t & 1
 analogue cards, remote nfs filesystem for /mnt/store, which contains
 symlinks (mythtv is setup to delete the symlink target as well when
 deleting a symlink).

 I've followed the instructions in http://www.mythtv.org/docs/mythtv-HOWTO-
 22.html#ss22.2, and the  extract for the crash shows as:


 {{{
 Thread 12 (Thread -1324663888 (LWP 29487)):
 #0  0xb62ff077 in memcpy () from /lib/tls/libc.so.6
 No symbol table info available.
 #1  0xb6ad5c49 in QString::operator+= () from /usr/lib/libqt-mt.so.3
 No symbol table info available.
 #2  0xb6ae4e22 in QStringList::join () from /usr/lib/libqt-mt.so.3
 No symbol table info available.
 #3  0xb705578f in WriteStringList (socket=0x85c3fc8, list=@0xb10b3610) at
 util.$
         str = {static null = {static null = <same as static member of an
 alread$
         utf8 = <incomplete type>
         size = -1230148090
         written = -1324666680
         payload = <incomplete type>
         errorcount = 3058273892
         retval = 182
 #4  0x0808a0ea in MainServer::SendResponse (this=0x8129ca8,
 socket=0x85c3fc8, c$
 No locals.

 }}}

 I'll attach the full gdb output.

 I've tried using valgrind but could not reproduce the problem within. Also
 tried electric-fence, but this SEGVs on startup.

 Please let me know if I help narrow this down.

-- 
Ticket URL: <http://svn.mythtv.org/trac/ticket/1751>
MythTV <http://www.mythtv.org/>
MythTV


More information about the mythtv-commits mailing list