[mythtv-commits] Re: Ticket #339: Simplify Tuning process

MythTV mythtv at cvs.mythtv.org
Thu Sep 22 05:32:12 UTC 2005

#339: Simplify Tuning process
 Reporter:  danielk  |        Owner:  danielk 
     Type:  task     |       Status:  assigned
 Priority:  major    |    Milestone:  0.19    
Component:  mythtv   |      Version:  head    
 Severity:  medium   |   Resolution:          
Comment (by ijr):

 Heh.  Sorry, but...  The tv_rec changes are pretty iffy, I think.  I don't
 understand why you like replacing member variable accesses with function
 calls.  It's not any easier to read, IMO, and liable to make things slower
 if the compiler doesn't decide those functions get inlined.  The extra
 macros aren't good, either, especially the verbose wrappers.  It just
 makes it harder to read if a section of code is using its own macros
 instead of the same functions everything else is.

 The recorders Pause 'unification' looks fairly meaningless.  Each of the 3
 major types has completely different pausing mechanisms, so it's not
 really unifying anything.

 The idea is to get _rid_ of the usleeps & polling, not add more. =)

Ticket URL: <http://cvs.mythtv.org/trac/ticket/339>
MythTV <http://www.mythtv.org/>

More information about the mythtv-commits mailing list